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The objective of IUGONET Project 

 promote effective use of the observational data 
spread across the institutes/universities, which leads 
to interdisciplinary, comprehensive studies of the 
upper atmosphere . 

 develop a metadata database of the upper 
atmosphere data by ground-based observation 
accumulated over 50 years since IGY by Japanese 
universities/institutes.  

 investigate mechanism of long-term variation in the 
upper atmosphere  

Participating universities and research institutes 
NIPR, PPARC, Tohoku Univ., STE Lab., Nagoya Univ., 
RISH, Kyoto Univ., WDC/Kyoto, Kyoto Univ., Kwasan 
and Hida Observatories, Kyoto Univ., and ICSWSE, 
Kyusyu Univ. 



Observations by IUGONET institutes 
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Altitude coverage of observations 
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Problem with databases 
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Database access through metadata DB 
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• Obs. time & loc. 
• Instrument type 
• Location of data file 
• Data format 
• Contact 
• … etc. 



Project Schematic 
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Project Timeline 

Task Y2009 Y2010 Y2011 Y2012 Y2013 Y2014 Detail 
Virtual information 
center (VIC) of UA 
studies 

System 
installation 

Normal 
operation 

System 
update 

Construct the integrated 
research environment (TV-
conference system, ..) 

Development of 
metadata DB 
system 

Prototype 
system devel. 
 

Regular 
system devel. 

Open to 
public  
 

Design and develop the 
metadata DB system 

Design the 
Metadata format 
standards 

Ver.1 format Update & 
document 

Release the format ver.1 
and keep updating if 
necessary 

Development of 
data analysis 
software 

Specifications 
and basic 
design  

Programming Open to 
public  

Develop and release 
analysis softwares for UA 
data  

Maintenance&exte
nsion of existing 
DBs of 
Observation data 

Maintenance  
of obs. DBs & 
exam. of non-
digital dataset 

Incorporate non-DB’d data 
into the DBs 

Metadata 
generation 

Collecting 
metdata from 
each obs. DB 

Generate metadata in the 
designated format and add 
to metadata DB 

Operation of 
metadata DB 

Release the metadata DB 
for community 

VIC extension to 
related fields 

Wrap up the project and 
discuss further extension 

Effort focused on old data from  
Y2012 on 

Effort focused on old data from 
Y2012 on 



IUGONET metadata format description 

We investigate many existing metadata formats in diverse way 
and choice one format for our base metadata format. 

IPY MDP 

ISTP 

PDS 

SPASE 

STARS 

DIF 

項目 IPY MDP, 
DIF

STARS, ISTP SPASE PDSラベル

フォーマット

やり取りする時のフォー
マット

XML XML XML テキスト

どの科学分野、どのDBが
使っているか

IPYDID, GCMD STP分野
STARS-DB, 
CDAWeb

STP, Heliospheric
VHO,VMO,ViRBO

Planetary
PDS

数値データセットを説明
する要素の有無 ○ ○ ○ ○
カタログデータセットを説
明する要素の有無 ○ ○ ○ △
非デジタルデータを説明
する要素の有無 △ × ○ ○
データファイルを説明する
要素の有無 × ○ ○ ○
可視化属性の有無

× ○ ○ △
必須(null不許可)の要素

数
8+18 21+72+18+26 (DB全

て)
15+7+7+6+3 8(+20)

新しい要素、単語の追加
が容易 × △ ○ △
ドキュメント、公開ツール
が揃っているか △ △ ○ ○

項目 IPY MDP, 
DIF

STARS, ISTP SPASE PDSラベル

フォーマット

やり取りする時のフォー
マット

XML XML XML テキスト

どの科学分野、どのDBが
使っているか

IPYDID, GCMD STP分野
STARS-DB, 
CDAWeb

STP, Heliospheric
VHO,VMO,ViRBO

Planetary
PDS

数値データセットを説明
する要素の有無 ○ ○ ○ ○
カタログデータセットを説
明する要素の有無 ○ ○ ○ △
非デジタルデータを説明
する要素の有無 △ × ○ ○
データファイルを説明する
要素の有無 × ○ ○ ○
可視化属性の有無

× ○ ○ △
必須(null不許可)の要素

数
8+18 21+72+18+26 (DB全

て)
15+7+7+6+3 8(+20)

新しい要素、単語の追加
が容易 × △ ○ △
ドキュメント、公開ツール
が揃っているか △ △ ○ ○



Design of metadata format 

IUGONET metadata format = SPASE + modifications 
What’s SPASE? 

metadata format developed by 
international consortium to 
comprehensively describe research 
resources regarding heliospheric and 
magnetospheric satellite observations 

 closely related to STP and upper atmosphere 
researches ( easy to use as a base format) 

new metadata elements & words appendable 
( customizable according to our data ) 

widely-used in VxOs ( possible metadata 
exchange in the future) 

(http://www.spase-group.org) 

IUGONET’s modifications 
 additional words to represent non-digital archives 
 additional words to represent heliospheric coordinates 
 new metadata elements to describe observation location & range 



Metadata examples 

ResourceID: space://IUGONET/NumericalData/EAR/RAO/EAR/trop_std_netcdf 
ResourceHeader: 
  ResourceName: EAR standard tropospheric observation mode 
  ReleaseDate: 2010-04-12 
  Description: Zonal, meridional, vertical winds, beam echo intensity, and spectral width 
                 data taken by the EAR operated in the standard … 
  Acknowledgement: If you acquire EAR data, we ask that you acknowledge us in … 
  Contact: 
    PersonID: spase://IUGONET/Person/EAR.Management.Group 
    Role: General Contact 
AccessInformation: 
  RepositoryID: spase://IUGONET/Repository/RISH/RISHDB 
  Availability: Online 
  AccessRights: Open 
  AccessURL: 
    URL: http://www.rish.kyoto-u.ac.jp/ear/data/index.html 
  Format: NetCDF 
… 

 Metadata of instrument, observatory, person, repository also created 
 Each metadata file written in XML 

Metadata of Numerical Data 



Project Timeline 

Task Y2009 Y2010 Y2011 Y2012 Y2013 Y2014 Detail 
Virtual information 
center (VIC) of UA 
studies 

System 
installation 

Normal 
operation 

System 
update 

Construct the integrated 
research environment (TV-
conference system, ..) 

Development of 
metadata DB 
system 

Prototype 
system devel. 
 

Regular 
system devel. 

Open to 
public  
 

Design and develop the 
metadata DB system 
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Metadata format 
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Ver.1 format Update & 
document 

Release the format ver.1 
and keep updating if 
necessary 

Development of 
data analysis 
software 

Specifications 
and basic 
design  

Programming Open to 
public  

Develop and release 
analysis softwares for UA 
data  

Maintenance&exte
nsion of existing 
DBs of 
Observation data 

Maintenance  
of obs. DBs & 
exam. of non-
digital dataset 

Incorporate non-DB’d data 
into the DBs 

Metadata 
generation 

Collecting 
metdata from 
each obs. DB 

Generate metadata in the 
designated format and add 
to metadata DB 

Operation of 
metadata DB 

Release the metadata DB 
for community 

VIC extension to 
related fields 

Wrap up the project and 
discuss further extension 

Effort focused on old data from  
Y2012 on 

Effort focused on old data from 
Y2012 on 



Development of MDB system 

IUGONET MDB system is based on 
an existing  repository software 
(DSpace). 

keyword 
search 

Time-range 
search 

Metadata list 

 able to register, search, collect, 
and provide metadata  

 able to handle arbitrary 
metadata formats  

 free, and widely used (e.g. 
digital university repositories)   



metadata 
Observation 
data 

e.g. 
Numerical data 
Figure 

e.g. 
Observation location,  
Instrument type, 
Start and end date, etc… 

 Metadata DB 

What is metadata? What is metadata database 

Metadata 
  Metadata,  is often used as “data about data”, has the information about the 
observation data.  e.g. observatory location, instrument type, start date, end date, data 
location, etc… 

Metadata database 
 Database which can control (gathering, searching, etc…) many metadata. 

metadata 



What is IUGONET metadata DB 

• IUGONET MDB provides the service for cross-searching observational data 
distributed across the IUGONET institutions. 

• IUGONET MDB brings a remarkable advancement in accessibility to the 
observational data and accelerate the interdisciplinary study. 

Freeword Search, 
Data type Selection, 
Visualized search, etc… 

Search Result 
(list or detail) 



Note for using IUGONET MDB 

• No registration 
• IUGONET MDB is welcome to any user.  People can search 

and refer all metadata in our database 
 

• Data usage restriction 
• If you want to use real data, conform to the data usage rules at 

each institute, and refer to acknowledgement section in 
metadata 



Access to IUGONET MDB 

Open your proper web browser, and access 

http://search.iugonet.org/iugonet/ 



All Simple search for all metadata 

Earth Advanced search for all metadata except solar image metadata 

Sun Advanced search for solar image metadata 

Spatial Visualized spatial search from observation network picture 

Appearance of IUGONET MDB 

Tabs for a variety of search objectives 



Input example keyword: “EISCAT” 

Freeword search 

Click “Search” 



Search Result (list) 

Cross-searching result: 
observational data distributed 
across two IUGONET institutions 



Search Result (detail) 

Related metadata is shown in the same 
page.  User can get many information 
just one query. 



Numerical Sample or observation values Person Information about the person 

Plot/Movie Data products can be images 
and movies 

Service Locations for functions 

DataFile/Plot individual files Document Information about the document 

Instrument Information about the instrument Annotation Assessments of a resource 
Observatory Information about the observatory Repository Locations for data 
Catalog Event lists Registry Locations for metadata 

What is data type? 

Data type indicates the type of metadata (Another name: Resource Type) 

Click here 



Advanced Search: Data Set 

Input keyword: “MAGDAS” 

Check Data Set (both Numerical  
and Plot/Movie) Click “Search” 



Advanced Search Result: Data Set 

Click this link to show details 



Advanced Search Result: Data Set 

Scroll down to 
AccessInformation 

Click the link at AccessURL You can access 
MAGDAS data website 
portal easily! 



Advanced Search: Data File 

Check Data File / Plot 

Uncheck Data Set (both 
Numerical  and Plot/Movie) 

Input keyword: “MF radar” 

Click “Search” 



Advanced Search Result: Data File 

Click this link to show details 

We got 85210 search results 



Advanced Search Result: Data File 

You can access the 
numerical data. 
Note: Respect data usage 
rule at each institute! 

Scroll down to Source 

Click the URL 



Advanced Search: Solar Image 

Select tab: “SUN” 

In this example, we use keyword “jpeg” to see solar image on the web browser. 

Check Data File / Plot 

Uncheck Data Set (both 
Numerical  and Plot/Movie) 

Input keyword: “SMART jpeg” 

Click “Search” 



Seamless browsing in 
IUGONET MDB 

Advanced Search Result: Solar Image 

Click this URL 



t 
to from 

E 
F 

Advanced Search: Time Range 

Input start date (from) and end date (to) which you interest 
in.  To show the date format , please click  icon [?]. 

Relationship between metadata start/end date and search scope 

D 
C 

B 
A 

In this case, IUGONET MDB search metadata B,C,D, and E 



Advanced Search: Spatial Search using GoogleMap 

Select tab: “Earth” 

Visualized spatial coverage search via GoogleMap API 

Click “view map” 



Advanced Search: Spatial Search (SUN) 

Select tab: “Sun” 

Select the kind of 
solar image: 
FullDisk and/or 
PartialRegion 

For more detail 
about the solar 
coordinate system, 
click [?] 



Advanced Search: Spatial Search (SUN) 

Select tab: “Earth” 

You can select the 
kind of solar image: 
FullDisk and/or 
PartialRegion 

For more detail 
about solar 
coordinate system, 
please click [?] 



Advanced Search: Entire Data / Resource List 

Brief overview of metadata 
registered on the IUGONET 
MDB. 

Click this URL 



Advanced Search: Visualized Spatial Search 

Select tab: “Spatial” 

Click “Solar telescope” 

Search result relate 
to solar telescope 



Help movie 

Click this URL 

Help movie list(in additional window) 



Method Example Explanation 

Search for all 
word(default) 

magnetogram kyoto or 
magnetogram AND kyoto 

Include space or AND (capitalized) between the 
words 

Search for either 
word 

magnetogram OR kyoto Include OR (capitalized) between the words 

Combination EISCAT (NIPR OR STEL)  
EISCAT AND (NIPR OR STEL) 

Put a phrase in parentheses 

exact word or 
phrase 

“magnetogram” Use quotes to search for an exact word or set of 
words in a specific order 

Exclude a word STEL-EISCAT Add a dash (-) before a word 

Method Example and explanation 

Unique search ResourceID:spase¥://IUGONET/Granule/STEL/Induction/ATH/induction/64hz_ergsc_cdf/stel 
_induction_ath_2010032623_cdf 

（explanation） Include “ResourceID:” before ResourceID.  In this case, apply an escape sequence to spase://.  Use  
backslash (spase¥://). 

Tree search ResourceID:spase¥://IUGONET/Granule/STEL/Induction/ATH/induction 

（explanation） View all metadata including this ResourceID 

Search Tips for the IUGONET MDB 

Every resource has a unique identifier (ResourceID) so that it can be 
tracked and referenced within a system. 



Project Timeline 

Task Y2009 Y2010 Y2011 Y2012 Y2013 Y2014 Detail 
Virtual information 
center (VIC) of UA 
studies 

System 
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Design and develop the 
metadata DB system 

Design the 
Metadata format 
standards 

Ver.1 format Update & 
document 

Release the format ver.1 
and keep updating if 
necessary 

Development of 
data analysis 
software 

Specifications 
and basic 
design  

Programming Open to 
public  

Develop and release 
analysis softwares for UA 
data  

Maintenance&exte
nsion of existing 
DBs of 
Observation data 

Maintenance  
of obs. DBs & 
exam. of non-
digital dataset 

Incorporate non-DB’d data 
into the DBs 

Metadata 
generation 

Collecting 
metdata from 
each obs. DB 

Generate metadata in the 
designated format and add 
to metadata DB 

Operation of 
metadata DB 

Release the metadata DB 
for community 

VIC extension to 
related fields 

Wrap up the project and 
discuss further extension 

Effort focused on old data from  
Y2012 on 

Effort focused on old data from 
Y2012 on 



Development of analysis software 

multiple, 
“stacked” plots 

GUI interface 

 Development of analysis 
and quick-look software for 
our observation data is on 
progress, in collaboration 
with the ERG Science 
Center.   

 The software is produced 
with the THEMIS science 
Data Analysis (TDAS) IDL 
libraries and is functioned 
on the free IDL Virtual 
Machine.  

 We discussed with TDAS 
team about our plug-in 
software package including 
GUI many times. 



Relationship between 
  UDAS, TDAS, IDL 

What is UDAS? 

• The IUGONET Data Analysis Software 
(UDAS) is the plug-in software for THEMIS 
Data Analysis Software suite (TDAS) 
 

• The IUGONET data (e.g., geomagnetic data, 
aurora data, radar data, and so forth), 
sattelite data (THEMIS, GOES, WIND, and 
ACE) can be handled. 
 

• It is possible to use many routines to 
visualize and analyze time series data. 
 

• It accesses the IUGONET data through the 
Internet, and then the data are automatically 
downloaded onto the user's computer 



TDAS（THEMIS  Data  Analysis  Software  suite） 

Developer 
・   UCB, UCLA 

Language 
・   IDL 

Data format 
・   CDF 

http://themis.ssl.berkeley.edu/software.shtml 



UDAS Website 

11 

UDAS website：http://www.iugonet.org/en/software.html 



Radar 

Geomag 

RadioTelescope 

UDAS Load Procedure v2.00.1 
http://www.iugonet.org/en/software/loadprocedures.html 



Example of visualization by using TDAS 
Time series stack plot Aurora 2D map 

FFT Wavelet 



Example of visualization by using UDAS 
IPRT 

EAR L-band Troposphere Radar 

Boundary Layer Radar 



SuperDARN EISCAT 

AE index 



Geomag（Syowa, Iceland） Geomag（210MM） 

Geomag（MAGDAS/CPMN） 



Help documents 

Command Reference HTML 
http://themis.ssl.berkeley.edu/socware/tdas_7_00/idl/_tdas_doc.html 
tdas_7_00/idl/_tdas_doc.html 
udas_2_00_1/_udas_doc.html 



Movies (How to use UDAS) 

IUGONET channel 
in YouTube 

http://www.youtube.com/user/iu
gonet2009/ 

http://www.youtube.com/user/iugonet2009/
http://www.youtube.com/user/iugonet2009/
http://www.youtube.com/user/iugonet2009/


UDAS GUI operation on IDL-VM 
Note:  
UDAS VM is *not released yet*.  
Please wait for a while until the UDAS VM will be released(in near future), or 
use UDAS under licensed IDL software. 



4. Select file 
thm_gui_new.sav 

 
3. Start IDL Virtual Machine 

UDAS on IDL  Virtual  Machine 

Click 

IDL Virtual Machine Initial Screen 

1. Get UDAS Virtual Machine application 
2. Extract zip file to your proper directory 

0. Get IDL Virtual Machine Environment 



UDAS on IDL  Virtual  Machine 

UDAS GUI Window! 



GUI Basic Operation 

File→Load Data  Click this icon 

Main Window Example: 
Load Dst index 

or 



① Click IUGONET Data Tab 

② Date and Time 
=2006-12-14 ～ 2006-12-16 

③ Instrument Type 
=geomagnetic_field_index 

Load Data Window 

* Uncheck “Use Single Day” 

GUI Basic Operation 



 
                

④ Choose parameters 

⑤ Click allow 

Load Data Window 

GUI Basic Operation 



⑥ Click“OK” 

Display of Data Policy 

Load Data Window 

GUI Basic Operation 



⑧ Click“Done” 

⑦ loaded data 

Load Data Window 

GUI Basic Operation 



Select 
Graph → 
Plot/Layout Options or Click this icon 

Next: Plot Dst index Main Window 

GUI Basic Operation 



Plot/Layout Options Window 

① Select 
data which 
you want to 
plot 

③ Selected Data 

④ Click OK 

② Click Line if you want to get line 
plotting 

GUI Basic Operation 



or 

Main Window Next: Load other data 

Select 
File→Load Data Click this icon 

Let’s load following data: 
ACE satellite 
Instrument: MFI 
Type: h0 
Parameter: BGSM 

Let’s load following data: 
ACE satellite 
Instrument: SWE 
Type: h0 
Parameter: V_GSE 

Let’s load following data: 
MAGDAS magnetometer 
(in IUGONET tab) 
Instrument: magnetometer 
Station: ASB 

GUI Basic Operation 



Load Data Window 
① Select ACE Data 

② Select mfi 

③ Select h0, BGSM 

④ Click arrow 

⑤ Loaded data 

GUI Basic Operation 



Load Data Window 
① Select ACE Data 

② Select swe 

③ Select h0, V_GSE 

④ Click arrow 

⑤ Loaded data 

GUI Basic Operation 



Load Data Window ① Select IUGONET Data 

② Select geomagnetic_field_fluxgate 

③ Select magdas, asb, * 

④ Click arrow 

⑤ Loaded data 

GUI Basic Operation 



④ Loaded data 

② Select V_GSE_x 

Plot/Layout Options Window 

Next: Plot V_GSE_x 

① Click button to add (remove) panel 

③ Click Line 

GUI Basic Operation 



Next: 
plot ACE mfi and 
ASB geomagnetic 
data 

GUI Basic Operation 



GUI Basic Operation 

③ Loaded data 

① Select mfi_BGSM 

Plot/Layout Options Window 

② Click Line 



GUI Basic Operation 

Plot/Layout Options Window 

③ Loaded data 

① Select magdas_mag_asb 

② Click Line 



Select Analysis→Calculate 
Next: 
Calculation 

GUI Basic Operation 



③ Added V_GSE_x 

Calculate Window 

② Click arrow 
① Select V_GSE_x 

GUI Basic Operation 



⑤ Click Run 

④ make equation 
 
"ace_h0_swe_V_GSE_x_new"= -1*"ace_h0_swe_V_GSE_x“ 

⑦ Click Done 

⑥ Get new value “V_GSE_x_new” 

Calculate Window 

GUI Basic Operation 



① Select V_GSE,  
and then click Remove 

Plot/Layout Options Window 

GUI Basic Operation 



③ Click Line 

② Select V_GSE_x_new 

④ Click OK 

Plot/Layout Options Window 

GUI Basic Operation 



Select Analysis→Data Processing 

Next: 
Data Processing – 
reduce spike noise, 
subtract average 

GUI Basic Operation 



Data Processing Window 

① Select data which 
you want to analyze ② Click right arrow 

③ Selected data 

④ Select analysis method 
“Clean Spikes” 

⑤ Click OK 

GUI Basic Operation 



Data Processing Window 

⑥ Selected data was 
changed 

⑦ Select analysis method 
“Subtract Average” 

⑧ Click Done 

GUI Basic Operation 



① Select Panel4  
and then click Remove 

Plot/Layout Options Window 

GUI Basic Operation 



③ Click Line 

② Select magdas_mag_asb-
despiked-d 

④ Click OK 

Plot/Layout Options Window 

GUI Basic Operation 



Select Analysis→Data Processing 

Next: 
Calculate Power 
Spectrum using Data 
Processing and Spec plot 

Component:  
magdas_mag_asb-despiked-d 
FFT parameter: 
  Window Size:64 
  Window Sift: 32 

GUI Basic Operation 



Data Processing Window 

① Select data which 
you want to analyze 

② Click right arrow 

③ Selected data 

④ Select analysis method 
“Power Spectrum” 

GUI Basic Operation 



Power Spectra Options 

⑥ Change parameters 

⑦ Click OK 

GUI Basic Operation 



Data Processing Window 

⑧ Calculated data 

⑨ Click Done 

GUI Basic Operation 



② Click Spec 

③ Added data 

Plot/Layout Options Window 

④ Click OK 

① Select data which 
you want to plot 

GUI Basic Operation 



Select Graph→X Axis Options 

Next: Change X axis 
parameter 

Tips for GUI Operation 



X Axis Options Window 

① Select Annotation 

② Select date:h:m 

③ Click OK 

Tips for GUI Operation 



X-axis was changed 

Next: Zoom in and 
Zoom out 

Click these icons 
(left:zoomin, right:zoomout) 

Tips for GUI Operation 



Tips for GUI Operation 

Next: Zoom in and 
Zoom out 

highlight the 
region by dragging 
the mouse over it, 
you will get 
zoomed in figure! 



Tips for GUI Operation 

Next: Zoom in and 
Zoom out 

put your mouse 
pointer over the plot, 
you will see the value 
at each plot. 



Tips for GUI Operation 

Next: Marking 

Select  Edit→Subset→Maker(All panels) 



Tips for GUI Operation 

② Put maker title 

Next: Marking 

① Hold down the 
Ctrl key, and then 
highlight the 
region by dragging 
the mouse over it. 



Tips for GUI Operation 

Marker and maker title 

Next: Marking 



Tips for GUI Operation 

Select File→Export To Image File 

Next: Save plot 
as file 



Tips for GUI Operation 

Marker and maker title 

Next: Save plot 
as file 

① Choose savepath 

② Choose filename 

③ Choose fileformat 

④ Click Save 



Conclusion 

Practice makes perfects! 



Website of IUGONET project 
http://www.iugonet.org/en/ 

To know more about this project, please visit this page at 
regular intervals as we are always posting the latest news. 

Thank you for your attention 
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